Opensourcetechブログ

OpensourcetechによるLinux・オープンソース・IT技術などに関するブログです。

nginx unit 1.7.1 リリース

 

 

こんにちは、LinuCエバンジェリストこと、鯨井貴博@opensourcetechです。

 

nginx unit の最新バージョン 1.7.1がリリースされました。

f:id:opensourcetech:20190209020344p:plain

nginx news

 

 

Changelogs

更新内容は、以下の通り。

脆弱性対応(CVE-2019-7401)とGoモジュールに関するビルドのバグフィックスです。

Unit security advisory (CVE-2019-7401)

Changes with Unit 1.7.1 07 Feb 2019

*) Security: a heap memory buffer overflow might have been caused in the
router process by a specially crafted request, potentially resulting
in a segmentation fault or other unspecified behavior
(CVE-2019-7401).

*) Bugfix: install of Go module failed without prior building of Unit
daemon; the bug had appeared in 1.7.

Unit 1.7.1 release

 

 

Changelogs(日本語訳)

unit 1.7.1の変更点 2019年2月7日
    *)セキュリティ:特別に細工された要求によってルータープロセスでヒープメモリバッファオーバーフローが引き起こされる可能性があり、その結果、セグメンテーションエラーまたはその他の不特定の動作が生じる可能性があった(CVE-2019-7401)。
     *)バグ修正:ユニットデーモンを事前にビルドせずにGoモジュールをインストールできなかった。 このバグは1.7に現れました。

 

なお、CVE-2019-7401については、以下を参照ください。

https://nvd.nist.gov/vuln/detail/CVE-2019-7401

https://www.linux.org.ru/news/security/14792414

 

 

 

www.slideshare.net

github.com

www.facebook.com

twitter.com

www.instagram.com

 

 

にほんブログ村 IT技術ブログ Linuxへ
Linux

にほんブログ村 IT技術ブログ オープンソースへ
オープンソース

 

 

Opensourcetech by Takahiro Kujirai